aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Gustavo Zacarias <gustavo@zacarias.com.ar>2015-11-20 13:00:50 -0300
committerGravatar Peter Korsgaard <peter@korsgaard.com>2015-11-25 23:25:42 +0100
commitf58a5d73abf2ff7b19f788c4776571fb08ffc391 (patch)
treeba81cf60248c4efc3f668402c0d1291ed6031e45
parentf5646333c3c94f56b0f20686c0eea54b332d5a7e (diff)
downloadbuildroot-f58a5d73abf2ff7b19f788c4776571fb08ffc391.tar.gz
buildroot-f58a5d73abf2ff7b19f788c4776571fb08ffc391.tar.bz2
libgtk3: mark wayland support as broken
As discussed on the list it requires a matching XDG runtime API level which is currently not the case (wayland/weston newer than libgtk3 at the moment). It doesn't normall exhibit build failures, but it fails at runtime regardless. Also fixes: http://autobuild.buildroot.net/results/aae/aae4266c16189b295cc7ceb60000c504ebb60752/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/libgtk3/Config.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libgtk3/Config.in b/package/libgtk3/Config.in
index cdc3b2db07..02c7aaf0c7 100644
--- a/package/libgtk3/Config.in
+++ b/package/libgtk3/Config.in
@@ -40,6 +40,8 @@ config BR2_PACKAGE_LIBGTK3_X11
config BR2_PACKAGE_LIBGTK3_WAYLAND
bool "GDK Wayland backend"
default y
+ # Needs a libgtk3 bump to match API level
+ depends on BROKEN
depends on BR2_PACKAGE_WAYLAND
select BR2_PACKAGE_LIBXKBCOMMON
help