aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Gustavo Zacarias <gustavo@zacarias.com.ar>2016-05-10 15:25:46 -0300
committerGravatar Peter Korsgaard <peter@korsgaard.com>2016-05-10 21:44:50 +0200
commit72b93bb6768654bc37e0dd9bc301a7ce5876962b (patch)
tree1f2ac5f00f5c4b8f4b67c4d4c65c38eaa7b45ae9
parentcc45fb08f3b34aba9b30a6d6f2fd4a6a9c4fe9f9 (diff)
downloadbuildroot-72b93bb6768654bc37e0dd9bc301a7ce5876962b.tar.gz
buildroot-72b93bb6768654bc37e0dd9bc301a7ce5876962b.tar.bz2
imagemagick: security bump to version 6.9.4-1
Fixes: Fix GetNextToken() off by one error. Check for buffer overflow in magick/draw.c/DrawStrokePolygon(). Remove support for internal ephemeral coder. These are all related to the recent ImageTragick bundle that were partially fixed in 6.9.3-10 as well. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/imagemagick/imagemagick.hash2
-rw-r--r--package/imagemagick/imagemagick.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/imagemagick/imagemagick.hash b/package/imagemagick/imagemagick.hash
index 135989ffcf..9a2a3eee56 100644
--- a/package/imagemagick/imagemagick.hash
+++ b/package/imagemagick/imagemagick.hash
@@ -1,2 +1,2 @@
# From http://www.imagemagick.org/download/releases/digest.rdf
-sha256 e33f021c879f31703f9e620f578ccf7d221a34941589da4bbe967b16a814336a ImageMagick-6.9.3-10.tar.xz
+sha256 2ea0fef839cd5d6f134502b7cf7ee0e57a3f230b19771515d4aa44354f4c6b3b ImageMagick-6.9.4-1.tar.xz
diff --git a/package/imagemagick/imagemagick.mk b/package/imagemagick/imagemagick.mk
index 8ecf5d6350..c952c2a5d1 100644
--- a/package/imagemagick/imagemagick.mk
+++ b/package/imagemagick/imagemagick.mk
@@ -4,7 +4,7 @@
#
################################################################################
-IMAGEMAGICK_VERSION = 6.9.3-10
+IMAGEMAGICK_VERSION = 6.9.4-1
IMAGEMAGICK_SOURCE = ImageMagick-$(IMAGEMAGICK_VERSION).tar.xz
IMAGEMAGICK_SITE = http://www.imagemagick.org/download/releases
IMAGEMAGICK_LICENSE = Apache-2.0