aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Fabrice Fontaine <fontaine.fabrice@gmail.com>2019-12-30 22:48:42 +0100
committerGravatar Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2020-01-23 23:36:29 +0100
commit6b0ba1a3c486e5ef649cd231ff1840fccc2767a6 (patch)
treed68f35ef1302cee7fb1e739ac084e1d5e247b1c2
parentc4a6f974b158a23bcab2f5e0e42971d0c15cc04b (diff)
downloadbuildroot-6b0ba1a3c486e5ef649cd231ff1840fccc2767a6.tar.gz
buildroot-6b0ba1a3c486e5ef649cd231ff1840fccc2767a6.tar.bz2
package/python-pyqt5: select BR2_PACKAGE_QT5BASE_GUI
Even though pyqt5 would be perfectly usable with just the core Qt5 modules (QtCore, QtDbus, ...), its configure.py script passes the -gui option to qmake unconditionally. Therefore, make sure that GUI is built. Fixes: - http://autobuild.buildroot.org/results/ea0c8db44aacf1ce76f75e8288969fe5da6690d9 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-rw-r--r--package/python-pyqt5/Config.in1
-rw-r--r--package/python-pyqt5/python-pyqt5.mk3
2 files changed, 2 insertions, 2 deletions
diff --git a/package/python-pyqt5/Config.in b/package/python-pyqt5/Config.in
index 20ac988703..9fa7676f98 100644
--- a/package/python-pyqt5/Config.in
+++ b/package/python-pyqt5/Config.in
@@ -5,6 +5,7 @@ config BR2_PACKAGE_PYTHON_PYQT5
bool "python-pyqt5"
depends on BR2_PACKAGE_QT5
select BR2_PACKAGE_PYTHON_SIP
+ select BR2_PACKAGE_QT5BASE_GUI
help
Python bindings for Qt 5
diff --git a/package/python-pyqt5/python-pyqt5.mk b/package/python-pyqt5/python-pyqt5.mk
index b6d559cd5b..260a93af9c 100644
--- a/package/python-pyqt5/python-pyqt5.mk
+++ b/package/python-pyqt5/python-pyqt5.mk
@@ -12,9 +12,8 @@ PYTHON_PYQT5_LICENSE_FILES = LICENSE
PYTHON_PYQT5_DEPENDENCIES = python-sip host-python-sip qt5base
PYTHON_PYQT5_MODULES = \
- QtCore \
+ QtCore QtGui \
$(if $(BR2_PACKAGE_QT5BASE_DBUS),QtDBus) \
- $(if $(BR2_PACKAGE_QT5BASE_GUI),QtGui) \
$(if $(BR2_PACKAGE_QT5BASE_NETWORK),QtNetwork) \
$(if $(BR2_PACKAGE_QT5BASE_OPENGL_LIB),QtOpenGL) \
$(if $(BR2_PACKAGE_QT5BASE_PRINTSUPPORT),QtPrintSupport) \