summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-02-24 11:00:02 (GMT)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-02-24 11:00:02 (GMT)
commita3c07d08eae55deeb1b1731174309750bb0ea628 (patch)
tree2c7a9a1a3e09b1748280a7a00e2eda6c11fa6dcf
parentce1dac2d429c34c1f60e58aa45c05fc17f8cbf5a (diff)
downloadbuildroot-a3c07d08eae55deeb1b1731174309750bb0ea628.tar.gz
buildroot-a3c07d08eae55deeb1b1731174309750bb0ea628.tar.bz2
util-linux: re-add <pkg>_AUTORECONF = YES
Commit a5015f1025a1aee173c2c2ab39ccac5ce38f30c3 ("util-linux: security bump to version 2.29.2") incorrectly removed <pkg>_AUTORECONF = YES. While the patches touching configure.ac have indeed been removed, there is still a patch touching a Makemodule.am file, which triggers an autoreconf a build time, which itself fails because autoconf/automake are not available. So re-add <pkg>_AUTORECONF, with a comment pointing specifically at the patch that makes it necessary. Fixes: http://autobuild.buildroot.net/results/309127a532eed00e406bbaf0b1a51b7241a10505/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/util-linux/util-linux.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index 0fc46d4..05e1398 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -9,6 +9,9 @@ UTIL_LINUX_VERSION = $(UTIL_LINUX_VERSION_MAJOR).2
UTIL_LINUX_SOURCE = util-linux-$(UTIL_LINUX_VERSION).tar.xz
UTIL_LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/util-linux/v$(UTIL_LINUX_VERSION_MAJOR)
+# 0001-build-sys-use-lm-for-scriptreplay-if-necessary.patch
+UTIL_LINUX_AUTORECONF = YES
+
# README.licensing claims that some files are GPLv2-only, but this is not true.
# Some files are GPLv3+ but only in tests.
UTIL_LINUX_LICENSE = GPLv2+, BSD-4c, LGPLv2.1+ (libblkid, libfdisk, libmount), BSD-3c (libuuid)