aboutsummaryrefslogtreecommitdiff
path: root/linux/Config.in
diff options
context:
space:
mode:
authorGravatar Romain Naour <romain.naour@gmail.com>2020-04-08 00:15:49 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2020-04-08 22:25:40 +0200
commit000d21c2b63bfda8c66edfd9a742a7b847c8b1a2 (patch)
treec32f656ad1264714ad7ab0f9c2deaeae307a0592 /linux/Config.in
parent5334d9a200f0b3c8df5db7ad7d609aeb32f62ec1 (diff)
downloadbuildroot-000d21c2b63bfda8c66edfd9a742a7b847c8b1a2.tar.gz
buildroot-000d21c2b63bfda8c66edfd9a742a7b847c8b1a2.tar.bz2
package/python-requests: relax version dependency on python-idna
The dockerCompose runtime test currently fails with: pkg_resources.ContextualVersionConflict: (idna 2.9 (/usr/lib/python3.8/site-packages), Requirement.parse('idna<2.9,>=2.5'), {'requests'}) This is due to the fact that the python-requests module has a strict version dependency on the python-idna module: 'idna>=2.5,<2.9'. Since Buildroot commit 237d31bf5289a46583aa4bbc1fb7ed008b798de5, we're using python-idna in version 2.9, which no longer matches the version dependency expressed by python-requests, causing the failure. Upstream has addressed this issue in commit https://github.com/psf/requests/commit/c46f55bd48dabc02f033d252f8c64e2011f37361, which relaxes the version requirement. Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/498144417 Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'linux/Config.in')
0 files changed, 0 insertions, 0 deletions