aboutsummaryrefslogtreecommitdiff
path: root/package/fwts
diff options
context:
space:
mode:
Diffstat (limited to 'package/fwts')
-rw-r--r--package/fwts/0001-build-do-not-use-Werror.patch8
-rw-r--r--package/fwts/Config.in8
-rw-r--r--package/fwts/fwts.hash4
-rw-r--r--package/fwts/fwts.mk4
4 files changed, 11 insertions, 13 deletions
diff --git a/package/fwts/0001-build-do-not-use-Werror.patch b/package/fwts/0001-build-do-not-use-Werror.patch
index c3ea2efc22..07f64b35b1 100644
--- a/package/fwts/0001-build-do-not-use-Werror.patch
+++ b/package/fwts/0001-build-do-not-use-Werror.patch
@@ -10,7 +10,7 @@ newer versions that introduce new warnings.
Remove use of -Werror.
Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
-[Fabrice: updated for 19.09.00]
+[Fabrice: updated for 20.08.00]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
configure.ac | 2 +-
@@ -40,9 +40,9 @@ index 52c637dd..d9d73f1c 100644
-pthread `pkg-config --cflags glib-2.0 gio-2.0` \
- -Wall -Werror -Wextra \
+ -Wall -Wextra \
- -Wno-address-of-packed-member
-
- bin_PROGRAMS = fwts
+ -Wno-address-of-packed-member \
+ -Wfloat-equal -Wmissing-declarations \
+ -Wno-long-long -Wredundant-decls -Wshadow \
diff --git a/src/lib/src/Makefile.am b/src/lib/src/Makefile.am
index 54de7f44..e129ed16 100644
--- a/src/lib/src/Makefile.am
diff --git a/package/fwts/Config.in b/package/fwts/Config.in
index 269f065fd5..ac9a2e3909 100644
--- a/package/fwts/Config.in
+++ b/package/fwts/Config.in
@@ -2,13 +2,12 @@ config BR2_PACKAGE_FWTS
bool "fwts"
depends on BR2_i386 || BR2_x86_64 || BR2_aarch64
depends on BR2_PACKAGE_LIBBSD_ARCH_SUPPORTS # libbsd
- depends on BR2_TOOLCHAIN_HAS_SYNC_4 # json-c
depends on BR2_USE_MMU # libglib2
depends on BR2_USE_WCHAR # libglib2, libbsd
depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2, libbsd
+ depends on !BR2_STATIC_LIBS # libbsd
depends on BR2_TOOLCHAIN_USES_GLIBC # execinfo.h
select BR2_PACKAGE_LIBGLIB2
- select BR2_PACKAGE_JSON_C
select BR2_PACKAGE_LIBBSD
help
Firmware Test Suite (FWTS) is a test suite that performs
@@ -33,10 +32,9 @@ comment "efi_runtime module needs a Linux kernel to be built"
depends on !BR2_LINUX_KERNEL
endif
-comment "fwts needs a glibc toolchain w/ wchar, threads"
+comment "fwts needs a glibc toolchain w/ wchar, threads, dynamic library"
depends on BR2_i386 || BR2_x86_64 || BR2_aarch64
depends on BR2_PACKAGE_LIBBSD_ARCH_SUPPORTS # libbsd
- depends on BR2_TOOLCHAIN_HAS_SYNC_4
depends on BR2_USE_MMU
depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
- !BR2_TOOLCHAIN_USES_GLIBC
+ !BR2_TOOLCHAIN_USES_GLIBC || BR2_STATIC_LIBS
diff --git a/package/fwts/fwts.hash b/package/fwts/fwts.hash
index 6338077732..9b05673152 100644
--- a/package/fwts/fwts.hash
+++ b/package/fwts/fwts.hash
@@ -1,5 +1,5 @@
# Hash from: http://fwts.ubuntu.com/release/SHA256SUMS
-sha256 91075982d067deef86d2830d622c27ed5f5c0b04dfd712902343a67fee753bfd fwts-V19.09.00.tar.gz
+sha256 bfe7993f1dd328b96a90ecfe92df67063df21afe4b4a103e498da6625c7c71b7 fwts-V20.08.00.tar.gz
# Hash for license file
-sha256 9cfdcde669bcdbd2eb640dca6ed3f9b5ae381d100ac208f9dca6e12e61ad639c debian/copyright
+sha256 379eab3c1071a6f5b8acd3632586577ec9c47ef10601b10467e890b8ff8b3842 debian/copyright
diff --git a/package/fwts/fwts.mk b/package/fwts/fwts.mk
index 853f27af49..e4e9defebf 100644
--- a/package/fwts/fwts.mk
+++ b/package/fwts/fwts.mk
@@ -4,14 +4,14 @@
#
################################################################################
-FWTS_VERSION = 19.09.00
+FWTS_VERSION = 20.08.00
FWTS_SOURCE = fwts-V$(FWTS_VERSION).tar.gz
FWTS_SITE = http://fwts.ubuntu.com/release
FWTS_STRIP_COMPONENTS = 0
FWTS_LICENSE = GPL-2.0, LGPL-2.1, Custom
FWTS_LICENSE_FILES = debian/copyright
FWTS_AUTORECONF = YES
-FWTS_DEPENDENCIES = host-bison host-flex host-pkgconf json-c libglib2 libbsd \
+FWTS_DEPENDENCIES = host-bison host-flex host-pkgconf libglib2 libbsd \
$(if $(BR2_PACKAGE_BASH_COMPLETION),bash-completion) \
$(if $(BR2_PACKAGE_DTC),dtc)