aboutsummaryrefslogtreecommitdiff
path: root/package/grpc/0002-Properly-detect-the-availability-of-pthread_setname_.patch
Commit message (Collapse)AuthorAgeFilesLines
* package/grpc: bump version to 1.32.0Gravatar Michael Nosthoff2020-09-191-2/+2
| | | | | | | | | - order dependencies alphabetically - update hash - alter patch offsets Signed-off-by: Michael Nosthoff <buildroot@heine.tech> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/grpc: bump version to 1.31.0Gravatar Michael Nosthoff2020-08-161-4/+3
| | | | | | | | | | | Related changes: - add dependency on Google RE2 package - update patches to new offsets Tested on Ubuntu 20.04 Signed-off-by: Michael Nosthoff <buildroot@heine.tech> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/grpc: bump version to 1.30.2Gravatar Adam Duskett2020-07-251-8/+8
| | | | | | | | | | | | | | Other changes: - Add a dependency on libabseil-cpp - Update the patches to apply properly. Tested with the following distributions: - Debian 9 - CentOS 7 - Fedora 32 Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/grpc: bump to version 1.25.0Gravatar Adam Duskett2019-12-081-4/+4
| | | | | | | | | | | | | | | | | | | | | | | Other changes: - Remove upstream patch 0004-Fix-gettid-naming-conflict.patch - Remove upstream patch 0005-Rename-gettid-functions.patch - Add a check for BR2_TOOLCHAIN_GCC_AT_LEAST_5 in grpc.mk. If the selected toolchain is not at least version 5 or higher and the optimization level is -Os, set the GRPC_CFLAGS and GRPC_CXXFLAGS optimizations to -O2. This check prevents the following error: error: failure memory model cannot be stronger than success memory model for '__atomic_compare_exchange' Tested with test-pkg, all tests passed: br-arm-full [1/6]: OK br-arm-cortex-a9-glibc [2/6]: OK br-arm-cortex-m4-full [3/6]: SKIPPED br-x86-64-musl [4/6]: OK br-arm-full-static [5/6]: SKIPPED Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/grpc: update to 1.18.0Gravatar Trent Piepho2019-03-171-5/+5
| | | | | | | | | | | | | Bump version. Freshen a patch that had a conflict. Remove duplicate env setting. Add comment about the hack being used to get gRPC to use the buildroot c-ares library. Otherwise it looks like the cmake env settings are out of date vs what the gRPC build documentation says to use. Signed-off-by: Trent Piepho <tpiepho@impinj.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/grpc: fix build on non-NPTL systemsGravatar Thomas Petazzoni2019-01-081-0/+52
uClibc-ng in non-NPTL configurations doesn't implement pthread_setname_np(). Unfortunately grpc assumes that as soon as __GLIBC__ is defined, pthread_setname_np() is available. It is particularly sad, because grpc build system uses CMake, so it is trivial to do such a check. This commit adds a patch that does just this: check for the availability of pthread_setname_np(), and use it only if available. The patch has been submitted upstream. Fixes: http://autobuild.buildroot.org/results/47991306abbcd80fb8e6baad0bd7490fa74f696c/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>