aboutsummaryrefslogtreecommitdiff
path: root/package/libpam-tacplus
Commit message (Collapse)AuthorAgeFilesLines
* package/libpam-tacplus: add CPE variablesGravatar Fabrice Fontaine2021-03-021-0/+2
| | | | | | | | | | cpe:2.3:a:pam_tacplus_project:pam_tacplus is a valid CPE identifier for this package: https://nvd.nist.gov/products/cpe/search/results?namingFormat=2.3&keyword=cpe%3A2.3%3Aa%3Apam_tacplus_project%3Apam_tacplus Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
* package/libpam-tacplus: remove duplicate LIBPAM_TACPLUS_AUTORECONFGravatar Romain Naour2020-11-161-2/+1
| | | | | | | | | | | | | | | | | The commit [1] added a second LIBPAM_TACPLUS_AUTORECONF because we are now patching configure.ac. But LIBPAM_TACPLUS_AUTORECONF was already used because the package is fetched from github. [1] bd85d82f61af0578a64e74e1cfb56c3c1bf46fe1 Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/849509860 Signed-off-by: Romain Naour <romain.naour@gmail.com> Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com> Reviewed-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libpam-tacplus: disable -WerrorGravatar Fabrice Fontaine2020-11-142-0/+58
| | | | | | | | Fixes: - http://autobuild.buildroot.org/results/5c17226f12eba104d907693ec37fc101cc6d447f Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libpam-tacplus: bump to version 1.6.1Gravatar Fabrice Fontaine2020-10-317-989/+3
| | | | | | | | - Drop all patches (already in version) - Update indentation in hash file (two spaces) Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/libpam-tacplus: fix CVE-2020-27743Gravatar Fabrice Fontaine2020-10-292-0/+149
| | | | | | | | | libtac in pam_tacplus through 1.5.1 lacks a check for a failure of RAND_bytes()/RAND_pseudo_bytes(). This could lead to use of a non-random/predictable session_id. Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/libpam-tacplus: fix build when time_t is 64 bitsGravatar Fabrice Fontaine2020-05-211-0/+80
| | | | | | | | Fixes: - http://autobuild.buildroot.org/results/874433d8cb30d21332f23024081a8b6d7b3254ae Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/libpam-tacplus: fix build on muslGravatar Fabrice Fontaine2020-04-212-0/+705
| | | | | | | Retrieve two upstream patches to fix build on musl Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* package/libpam-tacplus: add openssl optional dependencyGravatar Fabrice Fontaine2020-02-021-1/+3
| | | | | | | | | openssl is an optional dependency since version 1.4.1 and https://github.com/kravietz/pam_tacplus/commit/789cf4a85266dcb426ed133b2d07df86d0a55972 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Tested-by: Carlos Santos <unixmania@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libpam-tacplus: fix build on uclibcGravatar Fabrice Fontaine2020-02-021-0/+52
| | | | | | | | | Fixes: - http://autobuild.buildroot.org/results/05c67484136f3bb433ce7fc47b2ce01167048cc2 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Tested-by: Carlos Santos <unixmania@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package/libpam-tacplus: bump to version 1.5.1Gravatar Carlos Santos2020-01-204-73/+2
| | | | | | | | | | | - Remove all patches, already applied upstream. - Let PAM module be installed at the default place ($libdir/security). Fixes: http://autobuild.buildroot.net/results/cf15b09bd7501c017a4e8cf9fb80857197d4a433/ Signed-off-by: Carlos Santos <unixmania@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* package: remove 'v' prefix from github-fetched packagesGravatar Victor Huesca2019-06-192-3/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | On Github, a large number of projects name their tag vXYZ (i.e v3.0, v0.1, etc.). In some packages we do: <pkg>_VERSION = v0.3 <pkg>_SITE = $(call github foo,bar,$(<pkg>_VERSION)) And in some other packages we do: <pkg>_VERSION = 0.3 <pkg>_SITE = $(call github foo,bar,v$(<pkg>_VERSION)) I.e in one case we consider the version to be v0.3, in the other case we consider 0.3 to be the version. The problem with v0.3 is that when used in conjunction with release-monitoring.org, it doesn't work very well, because release-monitoring.org has the concept of "version prefix" and using that they drop the "v" prefix for the version. Therefore, a number of packages in Buildroot have a version that doesn't match with release-monitoring.org because Buildroot has 'v0.3' and release-monitoring.org has '0.3'. Since really the version number of 0.3, is makes sense to update our packages to drop this 'v'. This commit only addresses the (common) case of github packages where the prefix is simply 'v'. Other cases will be handled by separate commits. Also, there are a few cases that couldn't be handled mechanically that aren't covered by this commit. Signed-off-by: Victor Huesca <victor.huesca@bootlin.com> [Arnout: don't change flatbuffers, json-for-modern-cpp, libpagekite, python-scapy3k, softether] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
* package/libpam-tacplus: fix compilation with GCC 8Gravatar Carlos Santos2018-12-131-0/+39
| | | | | | | | | | | | | GCC 8 demands that the size of the string copied by strncpy be smaller than the size of the destination to keep space for the trailibg '\0'. This causes a compilation error in pam_tacplus, so add a patch already sent uptream to fix it. Fixes: http://autobuild.buildroot.net/results/da6d150e470046c03c5f7463de045604e15e4a30/ Signed-off-by: Carlos Santos <casantos@datacom.com.br> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* libpam-tacplus: bump to version 1.5.0-beta.2Gravatar Fabrice Fontaine2018-05-203-3/+33
| | | | | | | | | | - Remove LIBPAM_TACPLUS_AUTORECONF_OPTS as m4 directory doesn't exist anymore - Add patch to fix getrandom call (sent upstream) - Add hash for license file Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
* boot, linux, package: use SPDX short identifier for GPLv2/GPLv2+Gravatar Rahul Bedarkar2017-04-011-1/+1
| | | | | | | | | | | We want to use SPDX identifier for license strings as much as possible. SPDX short identifier for GPLv2/GPLv2+ is GPL-2.0/GPL-2.0+. This change is done by using following command. find . -name "*.mk" | xargs sed -ri '/LICENSE( )?[\+:]?=/s/\<GPLv2\>/GPL-2.0/g' Signed-off-by: Rahul Bedarkar <rahulbedarkar89@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
* package/libpam-tacplus: add .hash fileGravatar Romain Naour2016-06-181-0/+2
| | | | | | | | | Similar to jquery-keyboard, it seems the libpam-tacplus tarball on the autobuilder is corrupt. Fix it by adding a .hash file so it falls back to our s.b.o mirror. Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
* libpam-tacplus: new packageGravatar Giovanni Zantedeschi2015-08-282-0/+30
[Thomas: - change the inclusion location in package/Config.in to be with the other linux-pam plugins. - fix indentation of the Config.in file. - fix build of the package when a toolchain without SSP support is used. - fix installation location of the PAM module: it was installed in /usr/lib/security, while all other PAM modules are in /lib/security. - adjust the ordering of the variables in the .mk file to be a bit more logical. - remove passing of $(TARGET_CONFIGURE_OPTS) in <pkg>_CONF_ENV as it is not needed: it is already done by the autotools-package infrastructure.] Signed-off-by: Giovanni Zantedeschi <giovanni.zantedeschi@datacom.ind.br> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>