aboutsummaryrefslogtreecommitdiff
path: root/package/libgpiod/Config.in
blob: 63a7cb6e78d54635bca01e3d489425f4eed85af7 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
config BR2_PACKAGE_LIBGPIOD
	bool "libgpiod"
	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_8
	help
	  This is a C library that abstracts the GPIO character
	  device operations on linux.

	  https://github.com/brgl/libgpiod

if BR2_PACKAGE_LIBGPIOD

config BR2_PACKAGE_LIBGPIOD_TOOLS
	bool "install tools"
	help
	  Include a set of command-line tools for managing GPIOs.

endif

comment "libgpiod needs kernel headers >= 4.8"
	depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_8